Обновление пакетов в стабильных версиях Debian



By admin ~ Октябрь 30th, 2008. Filed under: Инсталляция.

Часто для серверов используют стабильные версии Debian, такие как Sarge, Etch, Lenny. Эти дистрибутивы не предполагают обновления программного обеспечения, а только закрытие багов и дыр. Использование в серверах версии Debian таких как Sid или Unstable не допустимо, из-за нестабильности и возможных проблем с безопасностью. Но иногда встает необходимость использовать новое программное обеспечение, такое как веб сервера или системы разработки. Именно для таких целей создан сайт http://backports.org. На нем представлены сборки популярных пакетов для стабильных версии Debian.

Рассмотрим случай, когда у нас Debian Etch и нам нужно обновить всего 1 пакет : nginx. Для этого добавляем в /etc/apt/sources.list строчку:

deb http://www.backports.org/debian etch-backports main contrib
non-free

и устанавливаем новый nginx

apt-get update
apt-get -t etch-backports install nginx

Вуаля. У нас стоит новый nginx. В сборке backports представлены не все пакеты, а только наиболее популярные. Так что вашего пакета там может не быть, но вы можете собрать его самостоятельно.

Маленькая подсказка, что бы не ругался aptitude выполните следущее:

wget -O - http://backports.org/debian/archive.key | apt-key add -

Это добавит ему новый ключ для проверки траста пакетов.

Popularity: 24%

Похожие статьи:

3 Responses to Обновление пакетов в стабильных версиях Debian

  1. Friendly

    Подскажите пожалуйста или ссылку на источник информации о отличии Sarge, Etch и Lenny.
    Заранее благодарен!

  2. Dasha

    Наличие где?

    В http://backports.org есть Sarge и Etch. Ленни еще развиваться )

  3. Friendly

    сам спросил -сам нашел)))
    http://www.debian.org/releases/

Оставьте комментарий: